Forum Index > Using Comm64 with System 3.5

By: Kenny Dewhirst Posted on: Sep 21 2011 at 07:30:48 PM
Is it at all possible to use Comm64 with System.dll version 3.5, rather than with 2.0? I'd like to replace a System.IO.Ports.SerialPort with a Comm64, but everything is already built on top of System 3.5 and my deployment environment only has 3.5.

By: Guest Posted on: Sep 21 2011 at 07:48:49 PM
Do you mean the 3.5 .net framework?

As far as I know an application that targets 3.5 can use components built using 2.0

If you're concerned that 2.0 might not be installed on the client machine then you shouldn't worry because 3.5 depends on 2.0 so 3.5 will not work unless 2.0 is also present.

By: Guest Posted on: Sep 21 2011 at 08:10:01 PM
FW3.0 is actually just 2.0 with a couple of extras such as WPF etc.

And then 3.5 just added a couple more such as Ajax.

3.5 does not include all the core components it simply calls down to the 2.0 components on which it depends.

So, any application targeting FW3.5 is actually still using the core 2.0 framework and won't work unless both 2.0 and 3.5 are both installed on the client machine. That's why the 3.5 framework deployment is so damn big. It also deploys the whole of 2.0 as well.

So, an application targeting 3.5 shouldn't have any problem using a component written for 2.0
I guess that's why the guys at Comm64 targeted that version of the FW

By: Kenny Dewhirst Posted on: Sep 21 2011 at 08:31:50 PM
Thank you for the quick replies!

I know that the higher versions are supposed to be supersets of the older ones, but when I try to build my project, I'm getting this error on the line where I try to define a Comm64 instance:

The type 'System.ComponentModel.Component' is defined in an assembly that is not referenced. You must add a reference to assembly 'System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'

And I already have a reference to System.dll version 3.5.0.0. Is there anything I can try?

By: Guest Posted on: Sep 22 2011 at 08:53:42 AM
You don'r mention Windows mobile but Remember that if you are targeting a mobile device then that may mean you're targeting the compact framework.

Comm64 is built for the full windows framework. It will work in any platform where the full framework exist.

Windows mobile devices use the compact framework which is a cut down version so assemblies that target the full framework wilt not work on such a device.

By: Support Posted on: Sep 22 2011 at 09:27:24 AM
Comm64 targets framework 2.0

We target that FW2.0 because it exists on most computers so no matter which framework the developer is targeting the application will work as long as FW2 is installed.

FW3 and FW3.5 are both based on FW2 so an application that targets 3.5 has the same dependencies as Comm64 so has no problem using that assembly.

FW4 is different. It is completely stand-alone so you can't assume that 2.0 exists especially on a brand new Win8 Machine so you ought to check.

I suppose we could release 3 and 3.5 versions but, as I said there is no benefit in doing that because those FW's are making calls down to FW2 anyway.

None of the above applies when targeting mobile devices using the compact framework. There is no version of Comm64 for the mobile/compact framework. We may make one one day but so far we haven't detected much of a demand for such a component.

By: Kenny Dewhirst Posted on: Sep 22 2011 at 06:32:58 PM
Ah, I bet that explains it. I'm on the 3.5 compact framework; sorry for not mentioning it. I would love to use your library, though, if it would be possible for you to do a version for the compact framework.

 

Reply - add comment to this topic
You may enter letters, numbers and standard punctuation only. HTML and other scripts/tags will be rejected
  Topic:- Using Comm64 with System 3.5

Your Name


 


Forum scripts and databases - Copyright (c) 2009 - 2012 AxCoL.com